About Us

RSInfoMinds, a web based IT Training and Consultancy firm. It is established with high dreams in training people in IT Infrastructure Field. We provide Online and Class Room training in various fields of IT Infrastructure Management.

Join Us: http://www.facebook.com/RSInfoMinds
Mail Us: rsinfominds@gmail.com
Twitter: @RSInfoMinds

We are specialized in the below courses:

Redhat Linux Admin Redhat Linux Cluster
Redhat Virutualization IBM AIX Admin
IBM AIX Virtualization IBM AIX Cluster
HP Unix Admin HP Unix Cluster
HP Unix Virtualization Shell Scripting
Veritas Volume Manager Veritas Cluster
Oracle Core DBA VMWare


We provide training in such a way, So that you get in depth knowledge on the Courses you look for.

And we ensure you are very confident from each and every Techincal aspect that the IT Industry needs and expects from you.

We also conduct Workshops on the latest technology and the real time faculties sharing their work experiences to make you the best.

Sunday 15 December 2013

Changing The Password In Linux Without Prompting

[root@node1 /]# echo -e "password" | (passwd --stdin rajasekar)
Changing password for user rajasekar.
passwd: all authentication tokens updated successfully.
[root@node1 /]#

Identify The Timezone In Linux


[root@node1 rhel5_x86_64]# cat /etc/sysconfig/clock
# The ZONE parameter is only evaluated by system-config-date.
# The timezone of the system is defined by the contents of /etc/localtime.
ZONE="America/New_York"
UTC=true
ARC=false
[root@node1 rhel5_x86_64]#

AIX Disk Mapping To LPAR

First the disk has to presented to the VIOS and then it will presented to the LPAR.

We look first at which VIO the LPAR belongs.

aixlpar01# lsrsrc IBM.ManagementServer
Resource Persistent Attributes for IBM.ManagementServer
resource 1:
        Name             = "10.0.0.1"
        Hostname         = "10.0.0.1"
        ManagerType      = "HMC"
        LocalHostname    = "10.0.0.2"
        ClusterTM        = "9078-160"
        ClusterSNum      = ""
        ActivePeerDomain = ""
        NodeNameList     = {"aixlpar01"}
aixlpar01#


We connect the VIO with padmin and scan the HBA’s.


$ ssh padmin@10.0.0.1
padmin@10.0.0.1's password:
Last unsuccessful login: Wed Dec 19 16:42:17 GMT+01:00 2012 on ssh
Last login: Wed Dec 19 16:42:47 GMT+01:00 2012 on /dev/pts/0

aixvio01$ cfgdev

Some error messages may contain invalid information
for the Virtual I/O Server environment.

Method error (/usr/lib/methods/cfgqlfscsi -l fscsi2 ):
        0514-061 Cannot find a child device.
Method error (/usr/lib/methods/cfgqlfscsi -l fscsi3 ):
        0514-061 Cannot find a child device.
aixvio01$


Now check for free disks:

aixvio01$ lspv -free
NAME            PVID                                SIZE(megabytes)
hdisk5          none                                153600
aixvio01$

hdisk5 is free but no PVID is assigned.

aixvio01$ chdev -dev hdisk5 -attr pv=yes
hdisk5 changed
aixvio01$

Now we need to find to which LPAR we have to assign (make a note of the LPAR ID).

aixvio01$ lssyscfg -r lpar -F lpar_id,name,state
1,aixvio01,Running
2,aixlpar01,Running
3,aixlpar02,Running
5,aixlpar03,Running
aixvio01$

Now assign the disk to the LPAR:

aixvio01$ lsmap -all | grep 0002
vhost3          U7778.23X.106DA2A-V1-C17              0x00000002
aixvio01$

aixvio01$ mkvdev -vdev hdisk5 -vadapter vhost3
vtscsi9 Available
aixvio01$

Run the cfgmgr on the LPAR:

aixlpar01# cfgmgr
aixlpar01# lspv
hdisk0          0006da2a3cdd9771                 rootvg     active
hdisk1          0006da0ab3df2fa6                 None

Linux Interview Question



1) Linux Booting Process.

2) What is swap memory ?

3) What is Multipath ?

4) How to scan a LUN ?

5) How to find WWN of HBA ?

6) How to create a FTP user ?

7) How to build a Kernel ?

8) What is MBR Reset ?

9) How to add a scrpit to default run level ?

10) What is tune2fs ?

Interface Speed Change In Linux


1) cp /etc/sysconfig/network-scripts/ifcfg-eth0 /tmp/

2) vi /etc/sysconfig/network-scripts/ifcfg-eth0

Append following line:
ETHTOOL_OPTS="speed 1000 duplex full autoneg on"

3)/etc/init.d/network restart

Verify the changes:

ethtool eth0

Boot Into On HPUX


HPUX > boot vmunuix : Comman to boot from a kernel.
HPUX > boot -is : Single User Mode: -i# : # Init Level.
HPUX > boot -tm : Tuneable Maintenance Mode (Fail Safe Mode)
HPUX > boot -lm : LVM Maintenance Mode.
HPUX > boot -mv : VxVM Maintenance Mode.