First the disk has to presented to the VIOS and then it will presented to the LPAR.
We look first at which VIO the LPAR belongs.
aixlpar01# lsrsrc IBM.ManagementServer
Resource Persistent Attributes for IBM.ManagementServer
resource 1:
Name = "10.0.0.1"
Hostname = "10.0.0.1"
ManagerType = "HMC"
LocalHostname = "10.0.0.2"
ClusterTM = "9078-160"
ClusterSNum = ""
ActivePeerDomain = ""
NodeNameList = {"aixlpar01"}
aixlpar01#
We connect the VIO with padmin and scan the HBA’s.
$ ssh padmin@10.0.0.1
padmin@10.0.0.1's password:
Last unsuccessful login: Wed Dec 19 16:42:17 GMT+01:00 2012 on ssh
Last login: Wed Dec 19 16:42:47 GMT+01:00 2012 on /dev/pts/0
aixvio01$ cfgdev
Some error messages may contain invalid information
for the Virtual I/O Server environment.
Method error (/usr/lib/methods/cfgqlfscsi -l fscsi2 ):
0514-061 Cannot find a child device.
Method error (/usr/lib/methods/cfgqlfscsi -l fscsi3 ):
0514-061 Cannot find a child device.
aixvio01$
Now check for free disks:
aixvio01$ lspv -free
NAME PVID SIZE(megabytes)
hdisk5 none 153600
aixvio01$
hdisk5 is free but no PVID is assigned.
aixvio01$ chdev -dev hdisk5 -attr pv=yes
hdisk5 changed
aixvio01$
Now we need to find to which LPAR we have to assign (make a note of the LPAR ID).
aixvio01$ lssyscfg -r lpar -F lpar_id,name,state
1,aixvio01,Running
2,aixlpar01,Running
3,aixlpar02,Running
5,aixlpar03,Running
aixvio01$
Now assign the disk to the LPAR:
aixvio01$ lsmap -all | grep 0002
vhost3 U7778.23X.106DA2A-V1-C17 0x00000002
aixvio01$
aixvio01$ mkvdev -vdev hdisk5 -vadapter vhost3
vtscsi9 Available
aixvio01$
Run the cfgmgr on the LPAR:
aixlpar01# cfgmgr
aixlpar01# lspv
hdisk0 0006da2a3cdd9771 rootvg active
hdisk1 0006da0ab3df2fa6 None
We look first at which VIO the LPAR belongs.
aixlpar01# lsrsrc IBM.ManagementServer
Resource Persistent Attributes for IBM.ManagementServer
resource 1:
Name = "10.0.0.1"
Hostname = "10.0.0.1"
ManagerType = "HMC"
LocalHostname = "10.0.0.2"
ClusterTM = "9078-160"
ClusterSNum = ""
ActivePeerDomain = ""
NodeNameList = {"aixlpar01"}
aixlpar01#
We connect the VIO with padmin and scan the HBA’s.
$ ssh padmin@10.0.0.1
padmin@10.0.0.1's password:
Last unsuccessful login: Wed Dec 19 16:42:17 GMT+01:00 2012 on ssh
Last login: Wed Dec 19 16:42:47 GMT+01:00 2012 on /dev/pts/0
aixvio01$ cfgdev
Some error messages may contain invalid information
for the Virtual I/O Server environment.
Method error (/usr/lib/methods/cfgqlfscsi -l fscsi2 ):
0514-061 Cannot find a child device.
Method error (/usr/lib/methods/cfgqlfscsi -l fscsi3 ):
0514-061 Cannot find a child device.
aixvio01$
Now check for free disks:
aixvio01$ lspv -free
NAME PVID SIZE(megabytes)
hdisk5 none 153600
aixvio01$
hdisk5 is free but no PVID is assigned.
aixvio01$ chdev -dev hdisk5 -attr pv=yes
hdisk5 changed
aixvio01$
Now we need to find to which LPAR we have to assign (make a note of the LPAR ID).
aixvio01$ lssyscfg -r lpar -F lpar_id,name,state
1,aixvio01,Running
2,aixlpar01,Running
3,aixlpar02,Running
5,aixlpar03,Running
aixvio01$
Now assign the disk to the LPAR:
aixvio01$ lsmap -all | grep 0002
vhost3 U7778.23X.106DA2A-V1-C17 0x00000002
aixvio01$
aixvio01$ mkvdev -vdev hdisk5 -vadapter vhost3
vtscsi9 Available
aixvio01$
Run the cfgmgr on the LPAR:
aixlpar01# cfgmgr
aixlpar01# lspv
hdisk0 0006da2a3cdd9771 rootvg active
hdisk1 0006da0ab3df2fa6 None
No comments:
Post a Comment