Splitting refers to the process of a breaking a mirrored Volume Group, which can be imported and used in a different AIX Machine or a LPAR. Applicaton Portability with less downtime are executed using the Splitting and Join Operation.
Scenario:
Consider an application configured on a volume group called "Application" which is made up of hdisk0 and hdisk1. And the application is mirrored.
Note: Only a mirrored volume group can be splitted.
Steps to Split:
1) # lsvg -o
2) # lsvg -l application /* Check the VG is mirrored */
3) # lsvg -p application /* PV's used to make the Volume Group*/
4) # splitvg -y <new vgname> -c 2 application /* Splitting application VG to a new VG, if no new name is givethen the VG is created with the default name vg00 */
5) New VG name is given as say "backupappln"
6) The VG "backupappln" is created in the PV hdisk. Where hdisk1 was a part of mirrored VG application.
7) Verify the new VG Created.
8) # lsvg - l backupappln
9) # lsvg -l application
10) # lsvg -p application
The output will still show that the VG application is made up of hdisk0 and hdisk1 but the state of hdisk1would be snapshotlv.
11) # lsvg -p backupappln
The output will show only the hdisk1
12) Now we export the VG backupappln to be used in a different machine. Before exporting the VG backupappln make sure that there is no Open Logical Volume and Varyoff the VG.
# varyoffvg backupappln
13) # exportvg backupappln
14) # rmdev -Rdl hdisk1 /* The disk hdisk1 has been removed from the AIX Machine */
15) # lsdev -l hdisk1 /* Ensure the hdisk1 is not shown */
16) Connect the hdisk1 to the required machine.
17) # cfgmgr /* Look for the newly connected device */
18) # lsdev -l hdisk1 /* Check the status of hdisk */
19) # importvg -y VG Name PV Name
VG Name : backupappln and PV Name : hdisk1
20) # lsvg -o /* Output will show the VG backupappln */
21) # lsvg -l backappln /* List the LV's in the VG */
22) By default all the LV's and mountpoints are prefixed with "fs".
23) # chlv -n newname oldname /* To change the name of the LV's
24) # chfs -m newmount point filesystem /* To change the mount point */
25) # mount -a /* To mount the file system *.
Scenario:
Consider an application configured on a volume group called "Application" which is made up of hdisk0 and hdisk1. And the application is mirrored.
Note: Only a mirrored volume group can be splitted.
Steps to Split:
1) # lsvg -o
2) # lsvg -l application /* Check the VG is mirrored */
3) # lsvg -p application /* PV's used to make the Volume Group*/
4) # splitvg -y <new vgname> -c 2 application /* Splitting application VG to a new VG, if no new name is givethen the VG is created with the default name vg00 */
5) New VG name is given as say "backupappln"
6) The VG "backupappln" is created in the PV hdisk. Where hdisk1 was a part of mirrored VG application.
7) Verify the new VG Created.
8) # lsvg - l backupappln
9) # lsvg -l application
10) # lsvg -p application
The output will still show that the VG application is made up of hdisk0 and hdisk1 but the state of hdisk1would be snapshotlv.
11) # lsvg -p backupappln
The output will show only the hdisk1
12) Now we export the VG backupappln to be used in a different machine. Before exporting the VG backupappln make sure that there is no Open Logical Volume and Varyoff the VG.
# varyoffvg backupappln
13) # exportvg backupappln
14) # rmdev -Rdl hdisk1 /* The disk hdisk1 has been removed from the AIX Machine */
15) # lsdev -l hdisk1 /* Ensure the hdisk1 is not shown */
16) Connect the hdisk1 to the required machine.
17) # cfgmgr /* Look for the newly connected device */
18) # lsdev -l hdisk1 /* Check the status of hdisk */
19) # importvg -y VG Name PV Name
VG Name : backupappln and PV Name : hdisk1
20) # lsvg -o /* Output will show the VG backupappln */
21) # lsvg -l backappln /* List the LV's in the VG */
22) By default all the LV's and mountpoints are prefixed with "fs".
23) # chlv -n newname oldname /* To change the name of the LV's
24) # chfs -m newmount point filesystem /* To change the mount point */
25) # mount -a /* To mount the file system *.
No comments:
Post a Comment